jQueryプラグインの競合

先日、ワードプレスのフォーラムで、

block UI requires jQuery v1.2.3 or later!You are using v1.11.2

というメッセージが表示される、という質問を挙げられている方がおられました。

結局はBlock UIプラグインとVideoPop Plusというプラグインの競合で、VideoPop Plusの使用をやめて解決されたようです。

でもこのメッセージ、「v1.11.2のjQueryを使っているけど、v1.2.3以降が必要です」というメッセージですよね。
今使っているv1.11.2の方がv1.2.3より新しいはずです。
どういうことでしょうか。

block UIのソースを見たわけではありませんが、jQueryのバージョンを文字列として比較してしまっているがゆえに、v1.11.2の方がv1.2.3より古い、という判断になっていると思われます。
つまり、v1.9.?までしかバージョンを予測していなかったんですね。

block UIは2010年に開発が停止した古いものですのでそのような仕様になっていたと思われます。
同じようなバージョンに矛盾のあるメッセージが表示される場合、プラグインが古いケースだと思いますのでバージョンアップすることが妥当です。

質問された方もできれば、似た機能の新しいプラグインを利用された方がよかったかとも思いました。
プラグイン自体も簡単にダイアログを表示できる便利そうなプラグインですが、残念です。

楽天市場

Amazon.co.jpアソシエイト

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)